Indice del forum Olimpo Informatico
I Forum di Zeus News
Leggi la newsletter gratuita - Attiva il Menu compatto
 
 FAQFAQ   CercaCerca   Lista utentiLista utenti   GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo   Messaggi privatiMessaggi privati   Log inLog in 

    Newsletter RSS Facebook Twitter Contatti Ricerca
Xubuntu: problema gestore energia
Nuovo argomento   Rispondi    Indice del forum -> *Ubuntu
Precedente :: Successivo  
Autore Messaggio
elisa.r
Semidio
Semidio


Registrato: 18/11/12 16:05
Messaggi: 289

MessaggioInviato: 04 Nov 2017 16:20    Oggetto: Xubuntu: problema gestore energia Rispondi citando

Ho cambiato l'hard disk e installato Xunbuntu (prima usavo Mint). Mi sembra che funzioni a a dovere, tranne appunto la gestione dell'energia, in particolare regolazione della luminosità e la sospensione dello schermo.

Adesso parte una lunga spiegazione, abbiate pazienza. Laughing

1 - Luminosità

Subito dopo l'installazione ho notato che era impossibile variare la luminosità dello schermo, sia tramite interfaccia (si può spostare il cursore avanti e indietro, ma non succede niente), sia da tastiera (appare la grafica, ma non si muove e la luminosità non varia).

Rovistando fra le varie impostazioni, alla fine ho scoperto che andando in Impostazioni > Gestore di energia (Generali) e togliendo la spunta a "Gestisci i tasti per la luminosità dello schermo", si riesce a regolare la luminosità tramite i tasti (l'indicazione grafica rimane però immobile), mentre resta impossibile regolarla tramite l'interfaccia.

Diciamo che il problema sarebbe parzialmente risolto, anche perché io solitamente uso i tasti, ma ovviamente non mi sono fermata e ho continuato a fare prove varie. Così ho scoperto qualcosa d strano.

Andando in Impostazioni > Editor delle impostazioni > Xfce4-power-manager e mettendo la spunta a "handle-brightness-keys" sia la regolazione della luminosità che la rispettiva indicazione grafica funzionano correttamente quando si regola la luminosità coi tasti. Tutto bene direte, invece no.

Le condizioni non si mantengono al successivo riavvio.

Nella nuova sessione mi ritrovo con la situazione seguente.

La spunta in Gestore energia è tornata (per via del fatto che nella sessione precedente l'avevo messa in Editor delle impostazioni) Agendo sui tasti varia l'indicazione della luminosità, ma non la luninosità stessa.
Se tolgo la spunta in Gestore energia, ritorno alla situazione iniziale, cioè luminosità regolabile, ma indicazione bloccata, nonostante la spunta in Editor delle impostazioni sia ancora presente. Se la tolgo e la rimetto, allora l'indicazione funziona correttamente.

Conclusione: l'unico modo per regolare la luminosità, coi tasti (ma sempre con l'indicazione bloccata) è togliere la spunta sia in Gestore che in Editor. Questa impostazione si mantiene ai successivi riavvii.
Non c'è modo di regoalre tramite interfaccia.


C'è dell'altro. Ieri ho installato il driver proprietario della scheda video. La regolazione della luminosità era perfettamente normale, sia da tasti che da interfaccia. Però il driver proprietario non lo posso usare perché mi dà problemi, quindi sono dovuta tornare all'open source.

Questo porta al secondo problema.


2-Sospensione dello schermo

Fino a ieri se il computer restava inattivo per tot minuti, si spegnava lo schermo. In Gestore di enegia ci sono tre voci "Sospendi" "Addormenta" e "Spegni" (non so che differenza ci sia) coi rispettivi tempi.
Comunque, dopo un certo periodo di inattività, lo schermo nero. Dopo essere tornata al driver open dopo aver provato il driver proprietario, lo schermo è sempre attivo. Ho anche provato a togliere la spunta a "Gestisci il risparmio energetico dello schermo", ma non cambia nulla.



Il problema dello schermo è ancora peggio di quello della luminosità, perché per quello comunque mi arrangio anche se funziona a metà.

C'è qualcosa che si può fare? Modificare qualche file di configurazione, o installare un software di gestione alternativo?


Uso Xubuntu 17.10- La scheda video è nVidia GeForce 9300M GS col driver open source.
Top
Profilo Invia messaggio privato
Maary79
Moderatrice Sistemi Operativi e Software
Moderatrice Sistemi Operativi e Software


Registrato: 08/02/12 12:23
Messaggi: 8156

MessaggioInviato: 06 Nov 2017 08:48    Oggetto: Rispondi citando

Controlla se hai installato acpi-support, dal gestore pacchetti.

Nel caso che già c'è l'hai ti linko il wiki di Ubuntu riguardo i parametri di avvio: link
Per cui proverei a disattivare acpi.

Oppure modificarlo come da guida: link

Per non modificare subito il file di configurazione del grub, quello puoi farlo dopo eventualmente, se funziona, puoi fare tutto dal grub stesso.
Dunque dopo aver premuto il tasto di accensione premi il tasto "esc", poi la "e" per modificare la riga come da wiki.

Che modello è il pc?
Top
Profilo Invia messaggio privato
elisa.r
Semidio
Semidio


Registrato: 18/11/12 16:05
Messaggi: 289

MessaggioInviato: 06 Nov 2017 15:38    Oggetto: Rispondi citando

Acpi-support è installato.

Ho seguito la seconda guida, perché non ho capito la prima (si può fare solo da live? non è chiaro).

Non ha risolto, anzi ha peggiorato il problema. Dopo il riavvio non riuscivo nemmeno a regolare la luminosità usando i tasti. Anche l'indicazione rimane ferma. Ho provato a rimettere la spunta alla gestione tasti. Così facendo si sposta il cursore grafico, ma senza risultati.

Il pc è Amilo Pi3540.
Top
Profilo Invia messaggio privato
Maary79
Moderatrice Sistemi Operativi e Software
Moderatrice Sistemi Operativi e Software


Registrato: 08/02/12 12:23
Messaggi: 8156

MessaggioInviato: 06 Nov 2017 18:37    Oggetto: Rispondi citando

Purtroppo sto leggendo vecchie discussioni di utenti con pc come il tuo, (una parte nel 2008 e finisce irrisolta nel 2012) con gpu Nvidia che segnalano proprio lo stesso tuo problema della luminosità (e i tasti FN in generale), sotto Linux, sia con il driver open che quello proprietario.
Ora ho comunque capito che il problema è rimasto solo con il driver open...insomma la Nvidia qualcosa ha risolto, solo che ha rotto da un'altra parte... Rolling Eyes

Altri invece hanno risolto modificando come indicato sulla guida Iffl.org.
da:
GRUB_CMDLINE_LINUX
a:
GRUB_CMDLINE_LINUX=”acpi_backlight=vendor”

La prima guida ti dice di modificare allo stesso modo il file del grub, mettendo

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off"

così lo spegni, di sicuro non risolve un tubo, ma era una prova, per vedere che faceva.

Altri utenti hanno risolto sempre modificando la solita riga del file del grub, in:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi="

Ricordati di dare:

Codice:
sudo update-grub


Dopo ogni modifica salvata.

Ricordati sempre ciò che modifichi. Per riportarlo allo stato iniziale.

Leggi anche questo, anche se è un po' vecchio come articolo, ma non so più che pesci pigliare!
link

Altrimenti aspetta che passino SverX o MK66...

Edit: puoi provare anche questo tool: link
Top
Profilo Invia messaggio privato
elisa.r
Semidio
Semidio


Registrato: 18/11/12 16:05
Messaggi: 289

MessaggioInviato: 06 Nov 2017 19:47    Oggetto: Rispondi citando

Ho provato GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off"

Così riesco a regolare coi tasti, ma l'indicazione grafica non appare proprio. Diciamo che così lo preferisco a prima perché se l'indicazione non funziona è inutile vederla. Anzi in realtà quando si usano i tasti è inutile in ogni caso, perché vedo da sola quando va bene.

Magari dopo provo le altre due soluzioni.

E per quanto riguarda il mancato spegnimento del monitor? Quella sarebbe una funzione importante.
Quello che mi turba è che all'inizio funzionava e ha smesso dopo che ho installato il driver nVidia. Deve essersi scombinato qualcosa che non è tornato come prima quando sono tornata al driver precedente. Confused
Top
Profilo Invia messaggio privato
Maary79
Moderatrice Sistemi Operativi e Software
Moderatrice Sistemi Operativi e Software


Registrato: 08/02/12 12:23
Messaggi: 8156

MessaggioInviato: 06 Nov 2017 19:55    Oggetto: Rispondi citando

Ok, bene, era la soluzione più semplice...ed è stata più utile di altre, comunque fai attenzione che sono 2 righe diverse da modificare, per le altre prove, presta attenzione.

Comunque i driver Nvidia c'è li hai ancora, te li ha installati il gestore, solo che ora hai selezionato gli open.
Sarebbero da togliere.
Prova a lanciare l'aggiornamento da terminale:

sudo apt update
sudo apt upgrade

Vedi se ti consiglia di rimuovere qualcosa con autoremove, altrimenti poi proviamo da terminale con:

Codice:
sudo apt-get --purge remove nvidia*


Poi vediamo per il monitor.
Top
Profilo Invia messaggio privato
MK66
Moderatore Sistemi Operativi
Moderatore Sistemi Operativi


Registrato: 17/10/06 22:24
Messaggi: 8448
Residenza: dentro una cassa sotto 3 metri di terra...

MessaggioInviato: 06 Nov 2017 20:17    Oggetto: Rispondi citando

Riesci a postare le schermate (o a dirci tutte le impostazioni) per ciascuna scheda di
Codice:
xfce4-power-manager-settings

(che sarebbe il comando da lanciare dal terminale per aprire il gestore di impostazioni energetiche di xfce)?
Top
Profilo Invia messaggio privato HomePage
elisa.r
Semidio
Semidio


Registrato: 18/11/12 16:05
Messaggi: 289

MessaggioInviato: 06 Nov 2017 20:47    Oggetto: Rispondi citando

Ho rimosso i pacchetti nVidia.
Nessun cambiamento.

Istantanea_2017-11-06_20-35-43.png


Istantanea_2017-11-06_20-35-53.png


Istantanea_2017-11-06_20-36-02.png

Istantanea_2017-11-06_20-36-08.png

Istantanea_2017-11-06_20-36-26.png

Non capisco perché non mostra le immagini in anteprima.
Top
Profilo Invia messaggio privato
Maary79
Moderatrice Sistemi Operativi e Software
Moderatrice Sistemi Operativi e Software


Registrato: 08/02/12 12:23
Messaggi: 8156

MessaggioInviato: 06 Nov 2017 22:11    Oggetto: Rispondi citando

Hai messo dei link per scaricare gli screenshot, diventa scomodo, wikisend lo usiamo per allegare i listati lunghi, tynipic per postare immagini.
Top
Profilo Invia messaggio privato
MK66
Moderatore Sistemi Operativi
Moderatore Sistemi Operativi


Registrato: 17/10/06 22:24
Messaggi: 8448
Residenza: dentro una cassa sotto 3 metri di terra...

MessaggioInviato: 06 Nov 2017 22:40    Oggetto: Rispondi

Infatti... Laughing
Comunque ho provato a darci uno sguardo, soprattutto confrontando col mio Xfce per individuare le differenze... Shocked

Allora, ti dico quali differenze ho io rispetto alle tue impostazioni, ma soprattutto cosa potrebbe, secondo me, dar problemi a Xfce (non è detto che la cosa si risolva, ma se ritieni che possa andar bene per il tuo caso specifico, nulla vieta di provare queste impostazioni: a me funzionano, a meno che non sia veramente un problema di incompatibilità con la scheda video... Think )

Scheda Generali

Non cambiare nulla: dovrebbe andar bene così


Scheda Sistema

Vanno bene i due "Sospendi" (a meno che vuoi attivare l'ibernazione, ma con xubuntu a volte da problemi, poi ci va una partizione di swap adeguata: in pratica la stessa dimensione della RAM + circa il 10%, per esempio 4 GB di RAM implica una partizione di swap di circa 4,5 GB, ma francamente Ubuntu & family la gestiscono un po' male l'ibernazione, quindi meglio evitarla... Wink )
I controlli sotto, dove hai i due cursori con scritto "Mai" in entrambi, io sposterei almeno il cursore dell'alimentazione da batteria, dando un certo tot di minuti di inattività dopo i quali il sistema va in sospensione.
Per il resto, quando arriva al 10% di batteria puoi anche dirgli di spegnere tutto, ovviamente devi fare attenzione te a non far scaricare la batteria, altrimenti ci perdi i lavori che stai facendo e non hai ancora salvato: io metterei almeno un "Chiedi" così ti appare una notifica che ti avvisa che sta per esaurirsi la batteria e spegnersi, e ti chiede cosa fare (almeno salvi i lavori che stai facendo)


Scheda Schermo

Di solito si mettono tempi più alti per alimentazione collegata alla rete, in quanto alimentato direttamente da batteria è più logico che sistemi di risparmio energetico intervengano prima, per ridurre i consumi della batteria stessa e salvare il lavoro.
Nel mio caso ho, nella colonna "da batteria" i tempi: 5, 10, 15 minuti e nella colonna "da rete elettrica" i tempi 10, 20, 40 minuti

Per la riduzione della luminosità, anch'io ho una riduzione apparente al 80% che non verrà MAI attuata se collegato alla presa, mentre se alimentato a batteria la riduzione della luminosità al 20% verrà attuata dopo 120 secondi (2 minuti) di inattività (regolazione del cursore in basso col primo "Mai", quello sotto il 20%)


Scheda Sicurezza

Il blocco della sessione (che sarebbe il fatto che ti chiede la password quando ritorni a usare il computer dopo che è partito il salvaschermo) va fatto col salvaschermo attivato (nel tuo caso è segnato dopo 1 secondo dall'avvio del salvaschermo, ma "quando il salvaschermo è disattivato", quindi c'è qualche problema di logica di funzionamento per Xfce)

Modificando quest'ultima voce, tieni presente che dovrai anche accedere alle impostazioni del salvaschermo, dove dovrai fare ulteriori accorgimenti che indico qua di seguito (in realtà dovrebbero essere automatici, ma meglio darci un'occhiata, che altrimenti si potrebbero creare situazioni in cui un programma chiede al sistema di agire in un modo e un altro chiede di agire diversamente nella stessa situazione: il sistema non sa più che fare e, se va bene, non fa assolutamente niente, altrimenti si rischia un bel crash: per esempio, windows ti mostrerebbe subito le sue qualità artistiche in pieno "periodo blu"... Shocked )

Quest'ultima modifica devi verificare che sia inserita anche nelle impostazioni relative al salvaschermo stesso, dove puoi anche scegliere di non usare nessun salvaschermo ma semplicemente far annerire lo schermo (scheda Modalità di visualizzazione) e soprattutto dai anche un'occhiata che non ci siano incongruenze nella Gestione dell'alimentazione del monitor (scheda Avanzate) dove dovrebbero essere attivate le stesse impostazioni che hai qua nella scheda Schermo (controlla: a volte capita che non si accordino)
Top
Profilo Invia messaggio privato HomePage
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> *Ubuntu Tutti i fusi orari sono GMT + 1 ora
Vai a 1, 2, 3, 4  Successivo
Pagina 1 di 4

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi