Indice del forum Olimpo Informatico
I Forum di Zeus News
Leggi la newsletter gratuita - Attiva il Menu compatto
 
 FAQFAQ   CercaCerca   Lista utentiLista utenti   GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo   Messaggi privatiMessaggi privati   Log inLog in 

    Newsletter RSS Facebook Twitter Contatti Ricerca
Debian: Installazione
Nuovo argomento   Rispondi    Indice del forum -> Linux
Precedente :: Successivo  
Autore Messaggio
kingofworms
Moderatore Internet e Telefonia
Moderatore Internet e Telefonia


Registrato: 12/09/03 23:01
Messaggi: 1654

MessaggioInviato: 09 Nov 2003 22:21    Oggetto: Dunque... Rispondi citando

Per la differenza tra insmod e modprobe, dai un'occhiata qui. Parla di schede di rete, ma spiega quello che serve sui due programmi.

Qui, invece, c'è qualcuno che pare avere un problema simile al tuo (magari l'hai già visto) e, stando a quanto c'è scritto, pare che il problema faccia parte delle opzioni attivate nella compilazione del kernel.

Per quanto riguarda soundcore, è - come dice il nome - il supporto fondamentale, (il centro, il nucleo - "core") per il suono (sound). Va attivato durante la compilazione del kernel alla voce Sound -> Sound Card Support. Qui (altro link che forse avrai già controllato), c'è una Guida all'installazione di ALSA, Advanced Linus Sound Architetture, per il chipset emu10k1 che potrebbe esserti utile.

Top
Profilo Invia messaggio privato
doctorK
Dio minore
Dio minore


Registrato: 10/06/02 21:09
Messaggi: 874

MessaggioInviato: 18 Nov 2003 00:07    Oggetto: dove eravamo rimasti? Rispondi citando

Jax, come butta?

alsa?

emu10k1?

il kernel?

Top
Profilo Invia messaggio privato
doctorK
Dio minore
Dio minore


Registrato: 10/06/02 21:09
Messaggi: 874

MessaggioInviato: 18 Nov 2003 00:08    Oggetto: Re: dove eravamo rimasti? Rispondi citando

e questo l'hai visto?

Top
Profilo Invia messaggio privato
jaxnife
Eroe
Eroe


Registrato: 18/09/03 11:25
Messaggi: 66

MessaggioInviato: 18 Nov 2003 08:41    Oggetto: Niente di nuovo sul fronte occidentale Rispondi citando

Purtroppo sono martoriato dagli esami e da "Dunque..." di king non ho visto nulla in pratica.



Il fatto che non funzionasse il driver di sourceforge.net nonostante venisse installato mi ha mandato in bestia, mi sono iscritto alla mailing list debian-italian, ma a parte tonnellate di SPAM&co non ho rimediato nulla di buono.



Mi sono cominciato a interessare a gentoo, che a quanto pare supporterebbe audigy semplicemente con alsa.

Devo dire però che è più complicato di Debian, la fregatura sta nel fatto che è stato progettato per essere un sistema in costante aggiornamento da Internet, le release fisiche su cd-rom sono più che altro un effetto collaterale... mah, staremo a vedere...

Top
Profilo Invia messaggio privato
jaxnife
Eroe
Eroe


Registrato: 18/09/03 11:25
Messaggi: 66

MessaggioInviato: 18 Nov 2003 10:19    Oggetto: Rettifica Rispondi citando

Mi sono confuso, "Dunque..." l'avevo già letto ma non ne ho ricavato nulla di utile purtroppo.



Mi sono accorto di un dettaglio però che potrebbe essere molto importante: modinfo soundcore dà esito negativo pur essendo stato compilato "built-in" nel kernel.

Che significa?

Top
Profilo Invia messaggio privato
kingofworms
Moderatore Internet e Telefonia
Moderatore Internet e Telefonia


Registrato: 12/09/03 23:01
Messaggi: 1654

MessaggioInviato: 18 Nov 2003 21:54    Oggetto: Re: Rettifica Rispondi citando

Quote:
modinfo soundcore dà esito negativo pur essendo stato compilato "built-in" nel kernel.




Direi che, se è compilato "built-in" (con l'asterisco, non con la M), non è un modulo, e quindi modinfo non può dare informazioni su un modulo che non c'è...

Top
Profilo Invia messaggio privato
jaxnife
Eroe
Eroe


Registrato: 18/09/03 11:25
Messaggi: 66

MessaggioInviato: 19 Nov 2003 10:29    Oggetto: Attivare i moduli Rispondi citando

Ah, ecco perchè! :ninja

Senti, mi spiegeresti come si attivano i moduli (perchè si devono attivare manualmente, giusto?)?

Top
Profilo Invia messaggio privato
kingofworms
Moderatore Internet e Telefonia
Moderatore Internet e Telefonia


Registrato: 12/09/03 23:01
Messaggi: 1654

MessaggioInviato: 19 Nov 2003 14:25    Oggetto: Re: Attivare i moduli Rispondi citando

Cercando conferme prima di scrivere stupidaggini, ho trovato questo (il che non elimina la possibilità di scrivere stupidaggini, ma almeno mi pare ridotta).

La frase chiave per il problema dei moduli è
Quote:
Alsa è diverso rispetto ad oss. Requisito essenziale è che il kernel

preveda il supporto dell'audio, ma non in modo monolitico.


Vale a dire che devi ricompilare il kernel e attivare il supporto per l'audio come modulo, e non built-in. Cioè ci deve essere la M e non l'asterisco (parlo per menuconfig, ma xconfig dovrebbe essere molto simile).

Top
Profilo Invia messaggio privato
jaxnife
Eroe
Eroe


Registrato: 18/09/03 11:25
Messaggi: 66

MessaggioInviato: 19 Nov 2003 21:13    Oggetto: M come... Rispondi citando

La faccenda del modulo/built-in l'avevo già capita, ma mi hanno detto che i moduli, dopo essere stati selezionati nel kernel che si va a compilare, devono essere proprio "accesi".



Il link si riferisce al pnp, che in Linux è notoriamente relegato al vetusto standard isa. :sick

Top
Profilo Invia messaggio privato
kingofworms
Moderatore Internet e Telefonia
Moderatore Internet e Telefonia


Registrato: 12/09/03 23:01
Messaggi: 1654

MessaggioInviato: 19 Nov 2003 22:08    Oggetto: Re: M come... Rispondi citando

Per "governare" i moduli in Debian c'è la comoda utility modconf.

Top
Profilo Invia messaggio privato
kingofworms
Moderatore Internet e Telefonia
Moderatore Internet e Telefonia


Registrato: 12/09/03 23:01
Messaggi: 1654

MessaggioInviato: 19 Nov 2003 22:13    Oggetto: Re: ah, il link... Rispondi citando

... voleva più che altro essere una conferma dell'indicazione. I suggerimenti sull'uso di modprobe per caricare i moduli "manualmente" è sempre corretto. Scusa se ogni tanto ripeto cose che sai già, ma ogni tanto ripeto semplicemente per ribadire, o non so che tu le sai, e tu non sai che io non so che tu le sai, e io non so che tu non sai che io non so che tu le sai...;)

Top
Profilo Invia messaggio privato
jaxnife
Eroe
Eroe


Registrato: 18/09/03 11:25
Messaggi: 66

MessaggioInviato: 20 Nov 2003 12:03    Oggetto: Modconf Rispondi citando

Se hai qualche link utile sull'utilizzo di modconf... 8o

Top
Profilo Invia messaggio privato
kingofworms
Moderatore Internet e Telefonia
Moderatore Internet e Telefonia


Registrato: 12/09/03 23:01
Messaggi: 1654

MessaggioInviato: 20 Nov 2003 13:50    Oggetto: Re: Modconf Rispondi citando

Riporto da qui:

Quote:
Il pacchetto modconf di Debian fornisce uno script di shell (/usr/sbin/modconf) che può essere usato per personalizzare la configurazione dei moduli. Questo script presenta un'interfaccia basata su menu che chiede all'utente particolari sui dispositivi driver caricabili nel suo sistema. Le risposte sono usate per personalizzare il file /etc/modules.conf (che elenca gli alias ed altri argomenti che devono essere usati in congiunzione con i vari moduli) attraverso i file in /etc/modutils/ e /etc/modules (che elenca i moduli che devono essere caricati all'avvio).



Come i (nuovi) file Configure.help sono ora disponibili per supportare la costruzione di kernel personalizzati, il pacchetto modconf nasce con una serie di file di aiuto (in /usr/lib/modules_help/) che forniscono informazioni dettagliate sugli argomenti appropriati per ognuno dei moduli.




In sostanza a procedura è simile a quella che hai usato per scegliere i moduli da includere nel kernel quando hai installato Debian. Avvii modconf come root e ti sposti tra menu e sottomenu. Per attivare (disattivare) il modulo che ti interessa, premi [Invio].



Al momento non ho sottomano qualche link chiaro; se trovo ti faccio sapere. L'uso è comunque intuitivo (parola che va per la maggiore e che usata per Debian sembra strana;) ).

Top
Profilo Invia messaggio privato
jaxnife
Eroe
Eroe


Registrato: 18/09/03 11:25
Messaggi: 66

MessaggioInviato: 21 Nov 2003 09:28    Oggetto: Modconf sostiene che... Rispondi citando

...il modulo per il supporto audio è già attivato di suo, ha un + per intenderci.

Tieni presente che prima di lanciarlo ho ricompilato il kernel con M per il supporto audio, infatti modinfo soundcore adesso non sclera più.

Ciò nonostante l'audio non funziona, l'ennesimo tentativo di modprobe emu10k1 mi ha dato lo stesso errore. :sad

Top
Profilo Invia messaggio privato
kingofworms
Moderatore Internet e Telefonia
Moderatore Internet e Telefonia


Registrato: 12/09/03 23:01
Messaggi: 1654

MessaggioInviato: 21 Nov 2003 17:29    Oggetto: Re: Modconf sostiene che... Rispondi citando

Intanto che penso/cerco qualcosa di più intelligente, puoi postare l'output di questo comando:

/usr/src/linux#grep -in 'CONFIG_SOUND' .config ?

(insomma, dalla directory dei tuoi sorgenti)

Così da controllare che nel kernel quel che serve sia attivo come dovrebbe.

Non ci spero, visto quanto ci hai lavorato, ma magari le cose più banali...

Top
Profilo Invia messaggio privato
jaxnife
Eroe
Eroe


Registrato: 18/09/03 11:25
Messaggi: 66

MessaggioInviato: 27 Nov 2003 18:00    Oggetto: Cosa ho fatto nel frattempo Rispondi citando

/usr/src/linux#grep -in 'CONFIG_SOUND' .config

ad essere sincero non l'ho trascritto al volo, indi mi sono scordato di provarlo. :shy



Lo farò quanto prima, comunque.

In questo periodo ho dato un'occhiata a Gentoo 1.4 e Slackware 9.1, nonchè ho smanettato con Debian.



Tutto questo, lo ricordo, è perchè non ammetto assolutamente di avere un sistema operativo senza audio! Su questo punto non transigo.



Gentoo 1.4 ha una struttura d'installazione ottimizzata per il remoto, la procedura offline ha una caratteristica a dir poco cretina: non installa i pacchetti cdrom->hd, ma cdrom->hd->(compila)->hd.

Non mi è piaciuta questa trovata idiota di spostare su hd tutto il contenuto del cdrom, come dicono di fare loro, inoltre kde non partiva e a dir la verità m'ha preso male quindi non mi sono neanche sbattuto perchè avvenisse il contrario.



Slackware 9.1, una delle distro più vecchie, rinomate e soprattutto considerata veramente ostica, devo ammettere che mi ha sorpreso con un'installazione davvero semplice e potente.

In un baleno mi son trovato KDE in italiano, cui ho aggiunto l'accelerazione 3D.



Per l'odissea della mia SoundBlaster Audigy Player credo dovrò ancora penare per un bel pezzo. Ho formattato Debian per un pastrocchio che non avevo voglia di sbrogliare, dopo la reinstallazione ho riprovato ad installare i driver alsa dell'alsaproject seguendo le loro stesse istruzioni invano.



Tutto funziona bene tra decompressione di pacchetti tar.bz2, compilazione e installazione di driver, purtroppo però il modprobe su emu10k1 non fa altro che abbaiare il solito errore (vedi post precedenti).



A questo punto penso proprio sia qualcosa legato agli IRQ, che nel BIOS non sono specificati, li ho lasciati credo ICU o quello che è insomma.

Sapete allora dirmi come faccio a conoscere gli IRQ da assegnare alla scheda audio e soprattutto come faccio poi ad assegnarli perchè quel maledetto driver funzioni?

Ci sentiamo.

:sick

Top
Profilo Invia messaggio privato
doctorK
Dio minore
Dio minore


Registrato: 10/06/02 21:09
Messaggi: 874

MessaggioInviato: 28 Nov 2003 01:27    Oggetto: Re: Cosa ho fatto nel frattempo Rispondi citando

Innanzitutto (ancora) complimenti per la costanza; dopotutto, se si possiede una audigy, BISOGNA farla funzionare ;)



Non ho mai provato Gentoo, ma credo che la procedura di 'download' su hd dei sorgenti avvenga perchè l'accesso a un disco è più veloce che ad un cd-rom.



per gli irq, dovresti trovare qualcosa nel bios oppure durante il rilevamento dell'hardware che il kernel compie subito dopo il boot. lo so, è veloce e illeggibile, ma il tutto viene trascritto in un file di cui non ricordo il percorso ma che dovrebbe trovarsi in /etc/log/



Ho fatto un giro sul sito della creative e sono finito nlla pagina per il dowload di drivers e altro. c'è un menu a tendina con TUTTI (circa) i SO mondiali ma, indovina?, impostando "linux" la risposta è questa:

Quote:
Spiacenti, non ci sono driver disponibili per la sua richiesta

Per favore andare indietro e correggere la richiesta


...

ma non si rendono conto che perdono clienti?

avranno qualche M$-contratto da rispettare...

Top
Profilo Invia messaggio privato
jaxnife
Eroe
Eroe


Registrato: 18/09/03 11:25
Messaggi: 66

MessaggioInviato: 28 Nov 2003 08:26    Oggetto: Audigy: o funziona o funziona o... Rispondi citando

...si passa alla terza opzione nascosta detta "tritarifiuti".



Se ho una scheda audio DEVE funzionare sotto Linux.

Il mio obiettivo non è cambiato, avere in Linux (non importa quale):

- accelerazione 3D (fatto :ninja )

- audio (maledizione!)

- internet (ho un Arescom Telindus ND220 USB ADSL, dovrò penare per fare accettare i Sagem).



Credo che il famoso log sia accessibile semplicemente col comando dmesg, ma non sono sicuro.

Non ho capito come si vedono gli IRQ in ogni caso. :-(

Top
Profilo Invia messaggio privato
jaxnife
Eroe
Eroe


Registrato: 18/09/03 11:25
Messaggi: 66

MessaggioInviato: 28 Nov 2003 20:49    Oggetto: Non trovo altre info utili Rispondi citando

Ho girato in rete cercando qualcosa di utile nei vari forum e ml facendo una ricerca con google, ma non è saltato fuori nulla di utile.



Alla fine gira e rigira la soluzione prospettata è sempre l'utilizzo del driver emu10k1-v0.20a messo a disposizione da sourceforge.net, solo che come ho già detto non riesce ad eseguire come Dio comanda "modprobe emu10k1".



Mi sto veramente inc*zz*nd* a morte per questa cosa, sento che il mio raggio d'azione ormai è al limite, credo di non essere abbastanza esperto per ottenere quello che voglio.



Aggiungo che il responso "ChissenefregadiLinux" by Creative è la prima cosa di cui mi sono accertato prima di rompermi la testa in questa maniera.



Sono sempre più convinto che la distro non centri proprio nulla con quell'errore, si tratta di condivisione di irq secondo me.

Mi sembra di aver capito che in teoria le impostazione degli irq dovrebbero essere prese da BIOS per evitare che Linux, per gli affari suoi, si convinca di cose strane facendo supposizioni errate.

Il BIOS però non ha nulla settato visto che Win si sistema da solo in questo senso.



Ho provato anche a installare i driver OSS, che non sono neanche freeware, ma l'output mi è sembrato interessante. Ovviamente hanno fallito, a questo punto è scontato e non c'è nemmeno bisogno di dirlo.



Piazzo qui il risultato dell'installazione del driver OSS e della stringa che Kingofworms ha scritto pochi post fa:



OSS, output dell'installazione:



nomepc:~ # cd /home/zaltar/opensound

nomepc:/home/zaltar/opensound# ls

opensound_istruz.txt oss399test-linux-v24.tar.gz

oss398b-linux-v2x.tar.gz oss_installing.txt

brothers:/home/zaltar/opensound# gunzip oss398b-linux-v2x.tar.gz

brothers:/home/zaltar/opensound# tar xvf oss398b-linux-v2x.tar

INSTALL

LICENSE

oss-install

oss.pkg

ui_X.so

ui_curses.so

brothers:/home/zaltar/opensound# ls

INSTALL oss.pkg ui_X.so

LICENSE oss398b-linux-v2x.tar ui_curses.so

opensound_istruz.txt oss399test-linux-v24.tar.gz

oss-install oss_installing.txt

brothers:/home/zaltar/opensound# chmod +x oss-install

brothers:/home/zaltar/opensound# ./oss-install

Checking for any previously installed sound drivers... You appear to have the th

e kernel level sound driver installed as a loadable

module. Unload it by executing rmmod sound and try installing OSS/Linux again.



If this error repeats again you probably have the sound driver being loaded

automagically by the kerneld daemon. In this case you should remove all sound.o

files from all subdirectories of /lib/modules in addition to executing

rmmod sound. After that you probably should reboot the system before trying to

install OSS again. Edit /etc/modules.conf and remove the 'alias sound ...'

line in case it exist and replace it by 'alias sound off'.



Also add a line containing 'alias char-major-14 off' to /etc/modules.conf.

Am I allowed to do these changes automatically for you (Y/N) ? y

Trying to disable the conflicting sound driver

/etc/modules.conf backed up to /etc/modules.conf.pre-oss

Unloading the existing sound driver

If your system freezes now, please reboot and disable the current driver manually.

Done.

NOTE! One or more PCI soundcards seem to share their IRQ with another card.

This may in some cases cause problems..

If your PCI soundcard is not functional, please use

BIOS PCI/PnP setup to allocate a private IRQ for the device.

However you don't need to be worried if everything appears to be working OK.

See /usr/lib/oss/docs/README.Irqsharing for more info.



The following IRQ number(s) appear to be shared:

15: (Shared with a non sound device(s))



47: (Shared with a non sound device(s))





* Open Sound System installation completed successfully *

Device configuration has been saved to /usr/lib/oss/devices.cfg

Execute /usr/lib/oss/soundconf if you want to change configuration.

Start the driver by using /usr/lib/oss/soundon command

See /usr/lib/oss/Readme for further instructions







*** Activating OSS and performing selftest ***





This Open Sound System copy is licensed for limited evaluation use only.

You can order the permanent OSS license using the 'Order permanent OSS license'

function of soundconf command. Alternatively use our ordering page at

www.opensound.com/order.html.



*** The evaluation time is limited to 3 hours ***



Your currently detected hardware combination works with the base OSS software

so you don't need to select any additional drivers when ordering the permanent OSS license.



Warning: Some of the devices failed to initialize.

See /usr/lib/oss/soundon.log for more info.



Some common system setup errors were detected:

1: PCI interrupt not allocated by BIOS



Please look at /usr/lib/oss/errors.log for troubleshooting instructions.



++++ osstest results ++++





NOTICE! You don't have any audio devices available.

It looks like your audio hardware was not recognized

by OSS. Please contact 4Front technologies for help

(www.opensound.com/support.cgi). Don't forget to include your soundon.log file to the support request.





*** Self test completed OK. OSS is ready for use. ***



----------------------------------------------------------------

Ecco qui, king:



nomepc:/usr/src/linux# grep -in 'CONFIG_SOUND' .config

790:CONFIG_SOUND=m

791:# CONFIG_SOUND_ALI5455 is not set

792:# CONFIG_SOUND_BT878 is not set

793:# CONFIG_SOUND_CMPCI is not set

794:# CONFIG_SOUND_EMU10K1 is not set

796:# CONFIG_SOUND_FUSION is not set

797:# CONFIG_SOUND_CS4281 is not set

798:# CONFIG_SOUND_ES1370 is not set

799:# CONFIG_SOUND_ES1371 is not set

800:# CONFIG_SOUND_ESSSOLO1 is not set

801:# CONFIG_SOUND_MAESTRO is not set

802:# CONFIG_SOUND_MAESTRO3 is not set

803:# CONFIG_SOUND_FORTE is not set

804:# CONFIG_SOUND_ICH is not set

805:# CONFIG_SOUND_RME96XX is not set

806:# CONFIG_SOUND_SONICVIBES is not set

807:# CONFIG_SOUND_TRIDENT is not set

808:# CONFIG_SOUND_MSNDCLAS is not set

809:# CONFIG_SOUND_MSNDPIN is not set

810:# CONFIG_SOUND_VIA82CXXX is not set

812:# CONFIG_SOUND_OSS is not set

813:# CONFIG_SOUND_TVMIXER is not set



Ho bisogno di sapere come impostare gli IRQ in modo da far funzionare quello stramaledetto driver di sourceforge.net. :dead

Top
Profilo Invia messaggio privato
kingofworms
Moderatore Internet e Telefonia
Moderatore Internet e Telefonia


Registrato: 12/09/03 23:01
Messaggi: 1654

MessaggioInviato: 28 Nov 2003 21:57    Oggetto: speranza? Rispondi

Visti i precedenti, è da prendere con le molle, ma il problema potrebbe essere qui:
Quote:
794:# CONFIG_SOUND_EMU10K1 is not set


EMU10k1 dovrebbe, infatti, essere attivato come modulo, altrimenti il driver di soundforge non può trovare il file emu10k1.o che gli serve. Quindi dovresti ricontrollare le scelte di menuconfig, nella sezione sound (non so dirti di preciso dove, al momento, perché non ho sottomano un computer con linux; appena riesco faccio ricerche) e ricompilare il kernel dopo aver attivato il modulo che si riferisce a emu10k1. Non ricordo come si presenta nel menu, ma mi pare di ricordare che non fosse troppo nascosto. Buona caccia!

Top
Profilo Invia messaggio privato
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> Linux Tutti i fusi orari sono GMT + 1 ora
Vai a Precedente  1, 2, 3, 4, 5, 6, 7  Successivo
Pagina 6 di 7

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi